New Alfa Romeo owner - need help. Cruise control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-09-11 Thread Starter
Status: -
Join Date: Sep 2011
Location: United Kingdom
County: Northamptonshire
Posts: 1
Help New Alfa Romeo owner - need help. Cruise control

Hi folks.

Finally got my hands on a lusso.
Everything's great, good price, 30000 on the clock.
Jobs a good'un.
Driving home after picking it up, everything was grand, all systems go.
I checked the cruise control and everything was great, dash indicator came on, car held the speed as it should but after one day it's not working. I've already checked the forum on here and the the buttons which touch the pedals are ok.
I haven't checked the fuse yet but if it turns out that the fuse is okay, is there anything else I should do.
I'm really gutted cause I love the car and this has kind of dampened the experience.

Anybody out there who can help???????
Stevo26 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Bristol
Posts: 90
Are you using the control properly? When it is on you need to turn the knob to either + or - to set the speed. Pressing the button on the end won't set the speed.
andy-ski is offline  
Status: bring back tapatalk
AO Silver Member
trashbat's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Hampshire
Posts: 2,518
As above, but if not, try (when safe) lifting the brake pedal from beneath using your foot and trying to set the speed again. On the 156 it seems it can be in a position that is not enough to make the brake lights come on, but is enough to disrupt the cruise control.
trashbat is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , control , cruise , owner , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome