Acceleration pedal position sensor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-09-11 Thread Starter
Status: -
Join Date: Jul 2011
Location: United Kingdom
County: Kent
Posts: 4

Member car:

Alfa Romeo 156

Acceleration pedal position sensor

Hi all
I need very quick help with part - accelerator pedal position sensor.
I have got Alfa Romeo 156 1.6 2001 Reg Y and i need to check what is accelerator pedal position sensor Bosch number.
Is : Bosch part 0281 002 386 (616) 186 307958 ok? I checked internet but it looks like Fiat Multipla one.
I'm sorry but I can't check one in my car at the moment.
nemo77 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
I've got one on my desk upstairs... I'll check it tonight.
iainfm is offline  
(Post Link) post #3 of 3 Old 12-09-11 Thread Starter
Status: -
Join Date: Jul 2011
Location: United Kingdom
County: Kent
Posts: 4

Member car:

Alfa Romeo 156

Took it anyway and will try it. Person who was breaking similar 2001 Alfa 156 1.6 said he had that one in his Alfa and was working fine. Could be possible it can be universal for Fiat/Alfa range? or me being naive
Story is: 3 weeks ago I took my Lady to mechanic because temperature has started to jump in strange way so I prayed - radiator and thermostat. Next day, phone call - accelerator pedal not working and ECU light on. Tried many things, Maf, lambda, wires, connectors, pipes, plugs, throttle position sensor, pedal position sensor, all tricks, computer...but couldn't clear faults and they gave up - computer is too much for them. But they pointed accelerator pedal position sensor as not working. Checked with Fiat brava one but no results.
After 2 weeks waiting angry I rang my breakdown assistance (lucky had it included in my insurance). Bloke came, checked with computer and said - def.: throttle position sensor but was checking pedal body under the dash. also there were about 5 other fauls but he was sure it is throttle position sensor.
Said - buy used throttle position sensor and replace it and should be ok. Took me and car home.
Managed to find used one with 90 days warranty, with friend disconnected old one connected new one , started engine and ...nothing. Engine started but no action, pedal not responding and throttle position sensor not responding and ECU light on. Should be ECU cleared (reset) when connect new one? Without computer we couldn't , we could only see new throttle reaction - well, no actionIs it possible , ECU will keep faults so connected new part was not working?
Well started to think about can of petrol and lighter but my MRS would do the same with me haha
Now funny thing and hope good sign.
On saturday spoke to nice alfaowner living not far from me. Recommended one garage near to me (where i went for MOT 2 years ago). Went today and guess what....another Alfa 156 was in garge ha ha
Booked for tomorrow morning. Throttle position sensor ready to be checked and accelerator pedal position sensor (my post above) on its way to me (should be tomorrow) . Hope one of those parts will do the job and after over 3 weeks I will come back sailing Well radiator and thermostat ready as well as soon as pedal will start responding.
Don't even say - it can be something else ha ha
But any help welcome.
Sorry for long story - alfaowner beautiful life!
Thanks in advance for all help and comments.
nemo77 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

acceleration , pedal , position , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome