alfa romeo 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-09-11 Thread Starter
Status: -
AO Member
Join Date: Sep 2011
Location: Greece
County: Ionian Islands
Posts: 20
alfa romeo 156

Guys hi my name is Andy from greece and recently (2 days a go ) i bought my new baby Alfa Romeo 156 1.6 ts .Second hand but in good condition i guess
but i have all ready a problem and i need your light to this .
My rear windows working perfect when i m operating them from the conctrol panel of the driver with out any problem , but indivitual from the local switch they don't work even the light comes up the night when y have the light on .the situation is getting me crazy and i need help .

thank you guys in advance
andygilios is offline  
Sponsored Links
Status: -
AO Member
lupos0_1's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Berkshire
Posts: 163
Is the window lock button on by the drivers control?
lupos0_1 is offline  
Status: -
AO Member
Sooty Si's Avatar
Join Date: Jun 2007
Posts: 395
I've found the switches can wear a bit internally. I fixed one by popping it out, taking it apart and inserting a slim piece of high-density foam between the switch and body internally to "push" it together so it made contact easier.

Sooty Si is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome