10 years, battery and rear box - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-09-11 Thread Starter
Status: -
AO Member
147cjl's Avatar
Join Date: Apr 2010
Location: United Kingdom
County: Falkirk
Posts: 226

Member car:

2002 147 1.6

10 years, battery and rear box

My 2002 147's battery gave up the ghost this week, but that was the original factory battery so it's lasted 9 and a half years which is pretty impressive. I was really surprised it had survived the last two winters. The breakdown guy who rescued my wife was gobsmacked.

I changed the rear exhaust today for a timax one, which looks ten times better. I'd put off this job for months but couldn't wait any longer. The box was a ******** to get off but got there in the end. Once i got the clamp off it slipped off not too bad. Again this was the original part and was still serviceable after all these years - just looked pig ugly and I'm glad to see the back of it.
147cjl is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Good stuff
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , box , rear , years

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome