stephen gray - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-09-11 Thread Starter
Status: -
Join Date: Sep 2011
Location: United Kingdom
County: North Yorkshire
Posts: 2

Member car:


stephen gray


Hoping for some help.

My |***** twin spark has the enine management light come on and also a light bulb symbol is on and flashes.
The car has just started holding back whilst driving, then kicks in and speeds up to what it should be doing.
Does this mean the spark plugs or air filter need changing, i am no mechanic so have no clue really.
Any suggestions would be helpfull.
stephen gray is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

these people have clue, they will run diagnostics and sort your problem out oh forgot its an alfa
davealfa11 is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
sounds like coil pack from that description, but could be other things as well, hence the diagnostics, the fault codes will be stored on the car, simply a matter of reading them to pinpoint the exact cause.

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gray , stephen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome