GT 1.9 jtd Clutch problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 06-09-11 Thread Starter
Status: -
Join Date: Sep 2011
Location: United Kingdom
County: Greater London
Posts: 5

Member car:


GT 1.9 jtd Clutch problem

Advice please.
I own a GT 1.9 jtd 56 plate with 55K miles on the clock. Sometime in the morning the Clutch is very soft and either goes strait down to the floor or has very little bite and I can not engage a gear properly, if I pump the clutch pedal then the clutch comes back to normal and I do not have any more problems until a the next morning or a few days later after the car has been standing for a while. Could it be the clutch slave cylinder or does the clutch need replacing or anything else?

Thanks in advance

Last edited by liddimenta; 14-06-12 at 14:09. Reason: STILL NEED HELP!!!
liddimenta is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , jtd , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome