Deceleration Judders - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
tooned g4
Status: - Update
Posts: n/a
Deceleration Judders

Hello all !
Just purchased my first Alfa - 2.0 selespeed ( `00 & 45k ) and sadly I have a problem allready . It judders when I take my foot off the gas.This seems to happen mostly in 3rd when slowing from 30 to 20 mph but slowing for traffic lights in 3rd or 2nd with no brakes and no gas will allways make it judder. It feels like a series of `Lunges` like the engine dos`nt know what to do (!?).Change up seems OK.Any ideas ?
I am still proud to own a 156 but these `Judders` must get sorted and someone must have an idea.
Also whats the best Alfa garage in S.E / Kent that has the best knolledge of 156`s. If my baby has to go under the spanner - i want the best not the rest !
Help me Obi-Wan , your my only hope !
Sponsored Links
Status: -
Join Date: Sep 2012
Location: Romania
County: Brasov
Posts: 3

Member car:

Alfa 156

Hello! I have the same problem.I know this is an old post, but if you solved I want to know what was the problem. Thanx
tsabaturk is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

deceleration , judders

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome