horn only works now and again - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 30-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: United Kingdom
County: Rhondda Cynon Taff
Posts: 2
Help horn only works now and again

Hi, I'v got a 156 selespeed 2.0 jts, and the horn only works now and again, when it works one press then thats it for a long time, it's as if it needs a rest. Anybody know.
skinny1107 is offline  
Sponsored Links
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
viagra perks the horn up so i have heard

sorry couldnt resist that one

on a serious side.....loose connection or broken wire

hdseven is offline  
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,966
Images: 5

Member car:

A galleon

trying................to...................resist. ........
Elvis Presley is offline  
Status: -
AO Member
156Matt's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: West Midlands
Posts: 158

Member car:

156 2.0 T Spark

clock spring connector block that sits behind airbag isn't making a connection against metal strips, or loose loom
156Matt is offline  
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
U Shaped connector behind the airbag has a broken track... Common fault on JTS 156's
biffa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

horn , works

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome