Alfa147-2001- 9cd boot changer-not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 28-08-11 Thread Starter
Status: -
AO Member
Join Date: Jul 2011
Location: Ireland
County: Tipperary
Posts: 29

Member car:

alfa 147 t spark

Alfa147-2001- 9cd boot changer-not working


the boot changer in my car hasn't worked since i bought it 2yrs ago

when i load it up with 8discs (1 compartment is missing) the cd player in the front says no disc 1-no disc 2 etc .........

the Boot changer is mechanically working as i can see it changing slots
is there a way to get the CD boot changer out without having to destroy the surrounding materials.........anyone know what could be wrong?

also while in the boot on oppisite side i find a stray wire...any idea what its for?
Attached Images
File Type: jpg 2yjsqk3.jpg (53.9 KB, 5 views)
File Type: jpg 24ozgnd.jpg (80.9 KB, 5 views)
checkraise is offline  
Sponsored Links
Status: sooo not missing my MX-3 :-D
AO Member
DeeJayB's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Derbyshire
Posts: 34
I got my 147 last week, so my advice may probably not be the best... however my changer also wasn't working correctly.
I got it working by removing the head unit from the dash, and then disconnecting the extra connectors (the coloured ones). Turned key to MAR and let the unit see no changer, then power off and reconnect.
Has worked pretty much OK since then. Even more reliable after I did an overnight battery charge.
Also (and forgive pointing this out) make sure your CDs are label side up in the holders... I had a couple the wrong way round
DeeJayB is offline  
Status: DB9 Top Gear Track
AO Silver Member
pubsinger's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: East Sussex
Posts: 1,629
Are you using original audio CDs or CD-R/RW loaded with mp3s?

If you've got connectivity between head and changer, which by the sound of it you have, then the changer can't read the CDs. Either the laser has curled up its toes, the CDs are not supported or maybe they're upside down as DJB has suggested.

All the best

pubsinger is offline  
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
the wire must be for a subwoofer...
satanism is offline  
(Post Link) post #5 of 5 Old 29-08-11 Thread Starter
Status: -
AO Member
Join Date: Jul 2011
Location: Ireland
County: Tipperary
Posts: 29

Member car:

alfa 147 t spark


yeah they're all proper CDs bought from shops.I also tried the CDs both sides up label up/down to make sure but still nothing....

Yeah i have connectivity between changer and cd player as when i load it u can hear the machine/changer changing the discs and on the dash CD player it is saying CD1-no disc CD2-no disc etc

i might give DeeJays plan a try and see does that work....

if not i guess maybe the lazer is buggered

@satanism- thanks

if its a thing the lazer is packed up and i want to change the boot changer over for another one same model etc how do i even go about getting the old one out? i have tried tugging on it and looking all around it but cant seem to see any screws/bolts/clips of any kind holding it in place....
checkraise is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

9cd , alfa , alfa147 , boot , changernot , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome