Broke it now i can't fix it :( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-08-11 Thread Starter
Status: -
AO Member
156Matt's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: West Midlands
Posts: 158

Member car:

156 2.0 T Spark

Broke it now i can't fix it :(

I changed the steering wheel on my 2000 156 and have broken 2 clock springs in the process, the 2nd one even though the wheel was at 12 o clock unlike last time for some reason it's still cracked the plastic on it, and exposed the ribbon inside, the horn now doesn't work whatsoever i'd checked the fuses all ok and there was no power to the white connector block which i believe is the horn one, other than testing the horn itself, does anyone have any other ideas of what it could be, needless to say i need a 3rd clock spring now

156Matt is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

broke , fix

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome