147 passenger window - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-08-11 Thread Starter
Status: -
Join Date: May 2009
Location: United Kingdom
County: Dorset
Posts: 4

Member car:

Mito TB 155

147 passenger window

My passenger electric window does not work from the passenger side switch. It will open and close no problem from the drivers side. I have tried 2 different switches with no joy. I do have illumination of the switch when ignition is on so there is some power there. The drivers side switches also bleep if the ignition is off and you try and activate them, the passenger switch does not bleep. I am thinking wiring?! Any ideas anyone?.....PLEASE!!!!!
justino is offline  
Sponsored Links
Status: -
Join Date: Jun 2010
Location: United Kingdom
County: Kent
Posts: 3
Any joy?

Hi Justino,

My window switch is doing the same thing now (but without the bleeping on the driver's side).

Did you manage to find a cure?

AlfamadMike is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , passenger , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome