Alfa 147 differential problem????? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: Ireland
County: Meath
Posts: 3

Member car:

147 lusso

Not Happy Alfa 147 differential problem?????

hi, i have an alfa 147 tspark 1.6 2002, when the car is jacked up at the front on both side and you put the car into gear and foot on accelerator, the wheels sometimes stop and start and the engine makes a clunking/rumbling noise and shakes like mad. just got timing belt, variator, rocket cover, drivers side drive shaft, front wishbones changed within the last week have had it a three garages so far When driving there was a clunking noise when changing gears and slowly putting your foot on accelerator, also when at top speed the car started to shudder and noise got louder and gear stick shook. Only got drive shaft done today and noise seems to be gone when driving, the noise is now only when car jacked up. wasnt sure if it could also be a problem with the differential. also when car is reversing up hills it makes a dragging noise, as if you still have handbrake on. also clutch is very heavy. ?? ?????????? thank you any advice would be really appreciated
alfa14723 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , differential , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome