Selespeed Actuator leak? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 19-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: Singapore
County: -
Posts: 2

Member car:


Selespeed Actuator leak?

Hi guys,

I posted previously on this thread. Help for new Alfa owner!!

At that time I didn't quite know what was were the issues so I just listed down all of them. Since then I had the wheel mounting changed which solved the wheel noises.

And I am starting a new thread just to focus on the Selespeed problem that I am still facing. I hope to get some advice from the community here.

Basically, the issue started as the gear not engaging despite numerous operation of the gear stick. It would go to neutral when stopped at traffic lights and it will not engage 1 or even if it did it would not go up from 1-2, 2-3 and so on.

The workshop adviced that I had a Actuator leak, which resulted in the level of the Selespeed oil being too low hence the gears won't change.

They want me to change a new Actuator which would cost 3.8K SGD. Too hefty a sum for a car that has only 2.5 yrs left before the scrap.

Apart from having to top up the Selespeed oil every 3 days, is there any other cheaper alternative to having to change the whole Actuator?

Your help would be much appreciated. Cheers!

hydrocort is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

actuator , leak , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome