156 JTDm climate control temp keeps rising - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 17-08-11 Thread Starter
Status: -
AO Member
rorystorm's Avatar
Join Date: Jun 2006
Location: gateshead
Posts: 207

Member car:

159 Ti 2.0jtdm

156 JTDm climate control temp keeps rising

Set dial at "Low" and blows cold air ( compressor running), but within minutes the temp display creeps up thro' the temp range to "Hi" as does the output through the unit ie heater starts blowing hot!!!
rorystorm is offline  
Sponsored Links
Status: bring back tapatalk
AO Silver Member
trashbat's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Hampshire
Posts: 2,518
Common fault. Dry solder joints in the climate controls. Mine does it too but only occasionally, and I was supposed to be buying one off a chap on here but he's buggered off.

You have to take it out and fix or replace; radio and centre console out, not too bad a job.
trashbat is offline  
Status: 17"wheels
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Hampshire
Posts: 390
WILSON_JTS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , climate , control , jtdm , rising , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome