rear windows - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-10-04 Thread Starter
Status: -
AO Member
Join Date: May 2003
Location: Norway
Posts: 46

Member car:

156 selespeed,02

Cry Like A Baby rear windows

Having a rear electric window problem, question it stuck or is it terminally broke ?

A few months ago, the lefthand rear window refused to move, but then did with a little persuasion (one person pushing on the window, one moving the switch, until it let go with a graunchy sound), this time even that hasn't helped, though I can here the motor trying to move. conclusion....broken? I have noticed that the door rubbers are very tight, is there a lubricant I can use on these to free it up - silicon spray or ?????

Also - if the worst comes to the worst, anybody got instructions for removing the door trim ? CAn't be so difficult to replace the motor, no special tool needed right ?
crafty2 is offline  
Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Re: rear windows

There was a thread on this same subject just a few days ago and no, its not hard to do.

Getting at everything will need some screwdrivers and a socket set (or spanners and thin wrists!).

The motor and winding unit come as one piece from alfa but I`ve had the motor out of mine seperately without too much trouble. Unfortunately yours sounds more like the winding assembly or cable as they can get stiff and rusty. Personally I`ve never been brave enough to attempt replacing that as I can`t quite see how its put together yet. That and not really enough time to do it

At least an investigation can be done by yourself easily enough.

If the rubbers are dry, use proper rubber lubricant because silicon can smear and is hard to clean off nicely.
Chris is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

rear , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome