alfa 156 intermittent start up problem also display keeps resetting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: Ireland
County: Dublin
Posts: 1

Member car:


Help alfa 156 intermittent start up problem also display keeps resetting

Hi All

Intermittently I turn key in engine won't start, or tick over or anything. Don't think its the known immobiliser fault as I don't get the key error, in fact the screen here goes black right as I'm turning the key (as opposed to all the oil, airbag,battery lights flashing up).
Only thing that fixes is opening door, getting out, locking and alarming with key fob, unlocking with key fob, getting in and turning key in ignition. This fixes evertime, fault only occurs 1 in 4 or 5 times starting the engine.
Also which I presume is connected, everytime I set the date for the display, it resets itself everytime I start the car up again, also clock losing 5 mins every couple of days.

I wanted to ask people in the know before getting hands too dirty as its my first ever alfa (so I don't know so much about cars..

1.8 - 2003 - 156 1.8 Lusso. ( amazing looking and amazing driving when it starts..)

Greatly appreciate any of your wisdom!
andersoc27 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2007
Location: United Kingdom
County: Staffordshire
Posts: 2,463
loose battery connection id start with.
italiaautoparts is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , display , intermittent , problem , resetting , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome