alfa 156 selespeed fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-08-11 Thread Starter
Status: [Too Long]
Join Date: Mar 2011
Location: United Kingdom
County: Anglesey
Posts: 8
Cry Like A Baby alfa 156 selespeed fault

Hi everyone , really need a hand on this one. Starting the car from cold the selespeed box selects the gears perfectly but as soon as the engine gets warm it has a mind of its own. Instead of changing up it skips into neutral. It can go from 2nd to 5th instead of 3rd. Also it will often show a different gear than the one selected e.g was in 2nd then its telling me im in 4th or 5th and even reverse sometimes, as soon as i pull over it drops straight into neutral. selespeed warning light comes on and buzzes too.

Iv'e checked the batt and thats fine, also checked the alternator and thats functioning fine, checked the selespeed oil but its a light yellow colour. only had the car 4 months so don't know what oil it is, saying that the car was fine when i bought it.

There is no alfa garage anywere near me and to be honest it wouldnt even get there.

Wheres the best area to start? anyone had this problem before and did they fix it without spending a fortune?


kopite80 is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
Download alfadiag or fiatecuscan and buy my cable to read out the selespeed error log
rarebear is offline  
(Post Link) post #3 of 3 Old 02-08-11 Thread Starter
Status: [Too Long]
Join Date: Mar 2011
Location: United Kingdom
County: Anglesey
Posts: 8
how much for the cable to get posted to the uk rarebear?
kopite80 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , fault , neutral , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome