Intermittent loss of power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: United Kingdom
County: Worcestershire
Posts: 2

Member car:

Alfa 147 Q2

Intermittent loss of power

Hi am new to site in the hope that someone out there can give me advice and/or help in solving this.
My 4yr old 147 Q2 has developed an intermittent loss of power, more so in the lower gears, it started when I was pulling onto a traffic island and then when depressed the throttle, nothing happened and was strandied with cars dodging me, eventually getting power back and went on my way. This has happened a couple of times, but the intermittent loss of power tends to happen when moving up the gears, particularly in the lower gears.
It feels like the engine has hiccuped - could it be something to do with the injector?
Sometimes it happens when cruising on m/way but that is barely noticeable.
I've had it serviced and MOT done since this started, and pointed the problem out to the garage but they could find nothing wrong, even when road tested.
I've had one of those fuel flushes done, but hasn't improved the problem.

Any suggestions?
sue168 is offline  
Sponsored Links
Status: -
Join Date: Aug 2010
Location: Czech Republic
County: Jihomoravský
Posts: 4
This could very well be a problem with the MAF, which is very difficult to detect. Even the diagnostics will not detect this

Try to clean the MAF or in worst case it needs to be replaced...

Just my opinion...problem could lie elsewhere too..

Hope it helps
samnelson82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

intermittent , loss , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome