Sportswagon boot cover wont roll back in! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-07-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2007
Location: United Kingdom
County: Staffordshire
Posts: 38
Images: 4
Sportswagon boot cover wont roll back in!

Hi I dont know if anyone can help but my 156 sportswagon boot cover wont roll back in - hubby has taken it apart and says the ratchet mechanism is fine, but there are two plastic 'spacers' which seem to have worn and wont work - anyone know where if this is a replacement part and where i can get some? Its just the boot cover, the mesh dog guard bit is fine.

Many thanks
Lisa Goodwin is offline  
Sponsored Links
Status: i'd rather push my alfa then drive a bmw
AO Member
vuk vucinic's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Bedfordshire
Posts: 117
Images: 6

Member car:

GT Jtdm


I had the same issue with mine and found a guide on on how to fix.

see link Alfa Romeo forum: Sportwagon Boot Cover is knackered

There is a few different ways on how to do it.

Hope it helps
vuk vucinic is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

back , boot , cover , roll , sportswagon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome