Getting better - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-07-11 Thread Starter
Status: Still very confused
AO Member
Join Date: Feb 2005
Location: United Kingdom
County: Cheshire
Posts: 844
Getting better

Well another week or two has passed by with my "new" JTS. I am slowly coming around. I decided that having read so much about cruise control I would look into it. Yep I found the connector attached to the steering column, good start, but I was finding it difficult to source a switch(no way am I paying dealer prices). I went to see Trish at Justalfa, in Liverpool, always good for stuff. She dug out a couple of switches from a 147 I think, certainly different to mine any way.
After a bit of messing about Trish told me to take it and try it out, if it's OK give her cash. Good people to deal with.
Anyway it was not going to fit as it was but as it had a section that fitted into a slot in the cover so I decided to cut all the other bits off and glue it into place. First I had to cut the slot, I made a template and used that to cut the section out. Doing this with a sharp modelling knife and then a file the job looked a good'un. Next glue into place, making sure that the thing is in the correct position. The last thing to do was connect the wiring, needless to say the connectors were different as was the wire colours, thanksto Petrolhead747 who in 2009 sussed it out and posted. I soldered in a computer connector so I could easily take it apart if needed and put it all together. Total time about one hour or so, tested it out and all seems well. I am well chuffed.

The car is growing on me and seems to be running better, maybe it's just because I have cleaned all connections, MAF, thottle body etc or maybe the additive I put into the fuel but I am happier than I was.

Boot spoiler next, just need to get it in colour first.

Last edited by Philjay50; 24-07-11 at 05:59.
Philjay50 is offline  
Sponsored Links
Status: getting my shit together
AO Member
pingu's Avatar
Join Date: Feb 2010
Location: Sweden
County: Stockholm
Posts: 140

Member car:

156 TS SW

Happy times!
pingu is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome