engine light is on after not driving for 3weeks - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-07-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: Surrey
Posts: 17

Member car:

alfa 156

engine light is on after not driving for 3weeks

hi all,

my 2001 156 2.0 ts has been parked up for 3weeks as its not drivable as my clutch and slave cylinder have completly gone.

i started the car up yesterday just to make sure the car started ok and the engine management light came on and stayed on....... im sure this wasnt on last time i could drive the car.......

i did notice from where i bled my clutch system 2 weeks ago i had left my MAF electrics disconnected so i have clipped that back on and re started the car but the EML is still on....

i cant even drive the car around the block as the clutch is stuck at the bottom so i cant even see if it goes off once driven but does anyone have any ideas why this light has now decided to come on???

would me dis connecting the battery for 24hrs reset it??

danny e is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Could have neen caused by starting with the MAF unplugged - Some faults clear themselves after a few 'good starts'
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

3weeks , driving , engine , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome