156 1.9 jtd ...mcsf = egr, maf or???? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 17-07-11 Thread Starter
Status: Am i addicted yet? Hell yeh!
Join Date: Apr 2011
Location: United Kingdom
County: Greater Manchester
Posts: 4

Member car:

156 1.9 JTD

Help 156 1.9 jtd ...mcsf = egr, maf or????

Hi Guys
Finally decided to post a question after reading hundreds of other answers on this site.
Bought my first beautiful alfa 156 a few months ago, however.........................
I randomly get a mcsf light when ever it feels like, there is no rhyme or reason to it, it general comes on then goes of, at will. when setting of from lights it will come on then with a bit of accleration it tends to clear, but occasionally it stay on and cannot be cleared (usually on a hot day if the car temperature is above 21 c).
I have taken off the egr and cleaned it out (it wasnt that dirty to be fair), no change, so thinking the egr was caput i blanked it off. Mcsf went away for about a day then its back.
I had AA out one day i was so fed it with it (it was a hot day so it wouldnt clear) the engineer said ecu was showing no errors he took egr apart and tested it .........apparently its ok. AA man reckons i need my air system cleaning?
I had a full service including air and fuel filter no change, mechanic did say my air filter was extremely dirty? suggested some high strength cleaner........how will stuff in my diesel clean air pipes?
So after going around in beautiful Alfa circles im at MAF sensor, i have disconnected it and engine is running no different, i do seem to have better pick up with no maf but mcsf is if nothing else more frequent now but still on and off.
Does anyone have any ideas?
P.s. When the AA man was out and the mcsf light stayed on the alfa was putting out black smoke with revs, which it also does if i have the mcsf on start up.
Need to get this sorted so no wether to buy a MAF or my beautiful Alfa tattoo
Any ideas would be greatly appreciated, thanks in advance x
claire156 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Hampshire
Posts: 124

Member car:

156 2.4 JTD

I would wait with the Alfa tattoo…

Alfa love affairs are usually short lived.

Ok, with the MAF;

IF there is no change when you disconnect the MAF, that would point at the MAF being faulty.

Why? IF disconnected, the ECU goes to “Default” settings= An estimated guess.

If the MAF would do his job, it should run better.

Why? The ECU would get actual readings and would not have to take a guess.

You could try to clean the MAF (you cannot break a broken part, right?).

Try carburettor cleaner or brake cleaner (@ £6), and a cotton bud.

Some have been lucky and it worked.

If you need a new one, avoid the cheap EBay items.

You can get the original Bosh one from most auto factors for @ £80

hope that makes sense

all the best


With an Alfa it’s a bit like with your very first Girlfriend.
Once you found out where everything is and what’s it’s used for, life becomes much more fun.
Got_one_two is offline  
Status: -
AO Silver Member
t3yls's Avatar
Join Date: Aug 2007
Location: Manchester
Posts: 2,810
Images: 4

Member car:

Alfa GT Jtdm

Originally Posted by claire156 View Post
I have taken off the egr and cleaned it out (it wasnt that dirty to be fair), no change, so thinking the egr was caput i blanked it off.
...if its blanked off that should cause a constant MCSF, i believe. So did you 'un-blank' it afterwards?
t3yls is offline  
(Post Link) post #4 of 6 Old 19-07-11 Thread Starter
Status: Am i addicted yet? Hell yeh!
Join Date: Apr 2011
Location: United Kingdom
County: Greater Manchester
Posts: 4

Member car:

156 1.9 JTD

Thanks Mike, too be honest pick up is better but i do seem to get mscf more frequently disconnected and engine feels lumpy at time (at least with maf connect its only mscf not lumpy too!). Im goning to clean MAF and Air intake manifold as it was full of **** when AA man kindly took off my egr and tested it. Thanks T3YLS I denfinately blanked it as i did it after cleaning didnt work, Im only an oscar winning blonde when it comes AA men trying to fix my car for free!
I keep you posted, cleaning it tommorrow. PS. Nah in still getting the alfa tattoo ive waiting years for the car and it!
claire156 is offline  
Status: love to get hold of the guy who invented the egr
AO Member
Join Date: Jul 2010
Location: United Kingdom
County: Leicestershire
Posts: 41
exactly the same problem with interminent problem on my 1.9 jtd.ive had the fault since i had the car ( a year now) but only just started to have power problems. took it to my local alfa specialists . i had air flow meter replaced but after a day the fault returned. so they blanked the egr off.nows runs fine still get the fault light on but car runs great. apprantley its all down to dirty air. so egr needs cleaning but most importantly the manifold needs removing and given a good clean out. i know youve just mentioned this but sounds like your heading in the right direction. by the way the air flow meter was going to be £181 + vat fitted - bosch but luckily they just started using an alternative from china £127 fitted all in + said theyve no probs with them. - good luck!
p47 is offline  
Status: Still driving a Volvo :/
AO Silver Member
Join Date: Feb 2009
Location: Ireland
County: Galway
Posts: 3,775
seeing as you have a lot of black smoke, i would suggest two things that havent been mentioned yet:

1) MAP sensor, if the EGR was dirty then this would have been clogged aswell so the ECU isnt getting good readings and the car acts like a dog nearly

2) Turbo hoses (you are kicking out lots of black smoke) you may have a split which would cause loss of power and it could throw up the mcsf light.

bear1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , egr , jtd , maf , mcsf

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome