Front Driver Side Electric Window - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-07-11 Thread Starter
Status: Waiting...always waiting...
AO Member
ZenWarrior's Avatar
Join Date: Aug 2010
Location: United Kingdom
County: South Yorkshire
Posts: 12
Front Driver Side Electric Window

Hi all. Hope someone can help with my frustrating problem!
I have a 156 TS 2.0 on a 51 plate. I have had the usual switch breaking on the drivers front window but have put up with pressing the contact with my finger until recently when it packed in altogether. Now, having read this forum I know that the switches for the windows should be interchangeable so I have swapped one of the back ones for the front one. However, the back one (with the old broken switch) works fine by pressing the contacts but the switch from the back does not work when connected to the front driver window!! I know all the switches actually work as I have tested them with all the other windows. I know its not the fuse as onoy one fuse controls both front windows and the passenger one works fine.
Does this mean I have a bad connection somewhere for the front drivers window - if so how do I find out??
Am I missing something else so obvious I can't see it ???

Cheers guys

ZenWarrior is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2007
Location: United Kingdom
County: Staffordshire
Posts: 2,463
passenger and rear switches fit into the drivers slot. you wont have one touch but its a much cheaper option to buying a whole switch. i have both in stock pm me if you need anything.
italiaautoparts is offline  
Status: Doesn't suffer fools gladly........
AO Member
Join Date: Dec 2004
Location: United Kingdom
County: Norfolk
Posts: 154
Good old Fiat problem with front windows.......same with Alfa? If there is a connector which separates the wiring at the door opening my guess is that's where the problem lies. Remove multiplug, apply WD40, and replace. Problem solved? Our Fiat JDT's driver's window problem confused me for ages and that was the problem. Presume all the switches are different - some with x4 and some with x5 wires, white or black bases - but looks like same as Fiat, so try the local scrapyard looking for the more upmarket Brava/Bravo/Marea.
Carrotsucker is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Only foolproof way to check is to take the doorcard off, reconnect the switchblock, unplug the connector to the motor and check for power when the switch is operated (there are only two wires, the switch merely connects pos and neg one way or the other) - if you have power, then the motor is likely to be the problem - if you don't have power, then a wiring fault within the door is the likely problem, I guess.
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

driver , electric , front , side , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome