GT clutch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-06-11 Thread Starter
Status: -
Join Date: Jul 2008
Posts: 2

Member car:

Alfa GT

GT clutch

I have an Alfa GT 1.9 JTD and I'm having problems with the clutch. It gradually gets closer to the floor before disengaging and sometimes will hit the floor with nothing there. The pressure - and disengagement - will return after repeated pumping of pedal. I have had the fluid changed but it is still doing it.

There doesn't seem to be a pattern to the changes, and it can go weeks without changing.

Any thoughts ?
9673brian is offline  
Sponsored Links
Status: -
AO Silver Member
Dickymint_156's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Somerset
Posts: 1,116
Images: 4
well i recon its the seals gone in either slave or master cylinder, look for a wet patch around the slave cylinder on the g/box
Dickymint_156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome