156 JTS engine control system failure... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-06-11 Thread Starter
Status: -
AO Member
156Matt's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: West Midlands
Posts: 158

Member car:

156 2.0 T Spark

156 JTS engine control system failure...

My brother has an 02 156 JTS and this morning the info centre gave him the message of engine control system failure and he says it has a serious misfire, I haven't seen the car yet so can't say too much more, but my guess would be to check the coils first, he's already had number 3 replaced a few months ago, so i was gonna check the others, anything else i should check like lambda's?

Thanks in advance
156Matt is offline  
Sponsored Links
Status: -
AO Member
alfanano's Avatar
Join Date: Jun 2002
Location: I would rather not say
County: -
Posts: 782
Images: 6

Member car:


Coil sounds very likely - they failed in pairs on my 156 JTS
alfanano is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , control , engine , failure , jts , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome