Help! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a


About 2 miles from home, noticed steering very heavy turning right at a junction - then, a very loud squealing/chirruping from the engine, related to engine revs. Sounds a bit like that slipping fanbelt thing you get in the winter. It's a 1.9JTD 16V with a remap.

Got home, opened bonnet and had a listen. Seems to be coming from offside/rear of engine. I think the heavy steering thing was a red herring, the steering fluid resevoir is full and there is no noise upon turning the steering wheel. Maybe the engine nearly stalled and caused the momentary heavy feeling?

Slightly strange smell coming from engine bay, no smoke or anything though. The engine wasn't overheated and all fluids are at full. I immediately thought 'turbo', but that is at the front of the engine, down below.

My second thought is maybe the timing belt, although that's only halfway through its life (hopefully), the car has done 90,000 miles and it was changed at 60,000.


(This post is also in the engine section of Technical & Vehicle Assistance, out of sheer desperation!)
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,287
Images: 12
Link to my reply in engine section ...
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome