Mental electrical fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-06-11 Thread Starter
Status: -
Join Date: Jun 2011
Location: United Kingdom
County: Suffolk
Posts: 1

Member car:

Alfa 156 2.5v6

Mental electrical fault

Hello all, need help. Have just changed the diff in my 156 v6 as the old one shattered, all is working o.k but I have been doing the odd hour here and there to get it done so the battery has been off for approx 6mths. The problem is the electrics, car starts and runs fine but o/s indicators stay on, main beam light and bulb failure light also do the same on the dash, the horn buzzes at the relay but doesn't work and a buzz comes from light stalk when you switch them on(but they don't actually come on). This doesn't happen straight away until you try and use one of the above. here's the odd bit....I connected my handeld diagnostics terminal to find no fault codes (didn't expect to) but everything works properly but as soon as it's disconnected it goes back to very broken electrics...please help cause I'm pulling my hair out and I don't have much left as it is. Thanks in advance.
slimspenny is offline  
Sponsored Links
Status: ...
AO Member
Join Date: May 2010
Location: United Kingdom
County: -
Posts: 387
Have you checked all the fuses?
Stibbs is offline  
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

disconnect battery and charge and refit in morning and check charging voltage see if former cures it or did you jump battery ?

oh and put heater in car to get rid of moisture thats being silly buggers with your electrics
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , fault , mental

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome