Selespeed Help Required - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-06-11 Thread Starter
Status: -
AO Member
Spark's Avatar
Join Date: Jul 2002
Location: United Kingdom
County: West Midlands
Posts: 318
Selespeed Help Required

My selespeed has probelems but i have been able to drive round them
However a much bigger problem has just presented itself I went out in it this morning & something didn't feel quite right so I got home and connected it to Fiat ecu scan checked for errors and none there checked clutch rod length and good at 28.3mm so i was doing a pressure check and thats when the problem started noticed that the pressure was going up after 2 gear changes so was watching it fall naturally using the graph function when the pressure got to about 42 pump kicked in but pressure did not rise and acctuator went nuts It sounded like all the actuators were for want of a better word "jiggling about when the pump was trying to prime I quickly removed the relay the "jiggling" went but now they just buzz.
Fluid tank full and overflow catch tank full
pressure no higher than 1bar
Hoping this is just accumulator failure
Spark is offline  
Sponsored Links
Status: -
AO Member
Cosmo156SS's Avatar
Join Date: Aug 2010
Location: I would rather not say
County: -
Posts: 436
Images: 2
For a start, check your battery terminals and voltage and clean the big connector on the actuator.
Cosmo156SS is offline  
Status: busy as a bee
AO Member
natasha147's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: West Yorkshire
Posts: 101
Images: 4
When i had the 147 selespeed lusso from new, after 3 years it struggled to change, and got errors. I got a new battery, problem solved.
natasha147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

required , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome