a/c turned on but it only makes consecutive 'tick' sound on regular interval - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-05-11 Thread Starter
Status: -
AO Member
seongtaek's Avatar
Join Date: Aug 2008
Location: Finland
County: Etela-Suomen Laani
Posts: 101
Images: 1

Member car:

156 JTS

Madness a/c turned on but it only makes consecutive 'tick' sound on regular interval


My car is JTS 03 156.
My A/C somtimes does work. But most of times when I turn on the A/C it will make a 'tick' sound as it tries to turn on the motor. But the motor is not running. It tries to turn on over and over again which makes 'tick' sound on regular interval of few seconds. I opened the hood and observed the a/c motor and it makes tick sound when it starts to rotate. But as it will stop after 1 second it will start again to rotate the motor. And then again and aagain......

This is making me crazy. How can I make my A/C working/fixed?

Please advise.
Thx in advance.

Alfa Romeo 156 2.0 JTS 2003 SW
seongtaek is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

a or c , consecutive , interval , makes , regular , sound , tick , turned

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome