Some problems with my 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-05-11 Thread Starter
Status: -
Vercetti's Avatar
Join Date: May 2011
Location: United Kingdom
County: Hertfordshire
Posts: 4
Some problems with my 147

Alright guys n gals its that time again.

I only just became a 147 owner and i have some questions i can't seem to find anywhere on the internet of Auto-data.

In fact that one of my problems how come there is very little information on the 147's As in Haynes manuals or Remove/Replace data.

I Recently replaced my Gear linkage Cables which in hine-sight was a dog of a job Afla engineering aren't mechanic friendly.

Now that i have gear movement, i really have to fight with the gear stick in the side to side motion, I'm suspecting the Gear selector plate and bushes. But i can't seem to track a replacement down.

Firstly am i right in thinking that the Gear Selector plate would be the main suspect in this problem?

And secondly.. The Car was stood still for some months before i got my hands on it and as a result there seems to be two electrical problems that i can't seem to explain.

The Mileage keeps flashing
and the CD player has no life in it at all..
(I've tracked fuses and wires its getting power but not coming on)

Any help would be grateful, Even if it borders on the insane.

Vercetti is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5

Gearstick - change the selector bushes in the turret on top of the gearbox (clean the hole thoroughly too)

Flashing odo - needs a proxy alignment performed on the CAN bus (FiatECUscan can do this).

Radio - maybe it's just broken!
iainfm is offline  
(Post Link) post #3 of 3 Old 21-05-11 Thread Starter
Status: -
Vercetti's Avatar
Join Date: May 2011
Location: United Kingdom
County: Hertfordshire
Posts: 4
Ahh That's very comforting to know that i might be able to just deep clean and copper grease some bushes on the pivot pin on top of the Gear box.

Would the Use of FiatECUscan identify if there is a problem with the CD unit?
I've basically never used it before and don't know much about it.

If not I've replaced CD units before but from what i understand from this unit is that it isn't a plug n play system and will have to be coded with the ECU to recognize it.

And any idea of how to Remove it as i can only see 6 small holes on the front panel nothing else, Is it a special tool job? Plus i don't want to damage the center console.
Vercetti is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome