rear windows and engine ticking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 21-05-11 Thread Starter
Status: -
Join Date: Apr 2011
Location: United Kingdom
County: North Yorkshire
Posts: 3

Member car:

156 lusso saloon

rear windows and engine ticking

Hi my rear windows won't open sound like they are trying to open wondering if there is a lock or seperate fuse. also my engine is ticking seems to run ok just sounds rubbish.
thanks for your help
moontheloon is offline  
Sponsored Links
Status: obsessed
AO Silver Member
Loknar's Avatar
Join Date: Mar 2011
Location: Thailand
County: Bangkok
Posts: 1,407
Images: 76
Maybe your aux belt is dangerously old? Just my novice advice.. if it does not feel normal, please take care of it...
Loknar is offline  
Status: - Update
Posts: n/a
Worth getting that engine ticking checked out.

Got mine back from the garage yesterday after a spark plug blowing and setting my engine on fire, (thread on here).

The ticking sound symptom I had was exactly the same sound as an hydraulic lifter or leaking manifold gasket, neither of which are as serious.

Don't want to scare you, and I may be being a bit paranoid after what happened to me, but would hate to see it happen to anyone else.
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
Rear windows not operating may well just be the glass sticking in the runners - worth running a thin blade around between the glass and the seals, then getting someone to operate the switch whilst you try to assist the glass down with a hand on each side of the glass.....

If you get them moving, some silicone lube in the runners is worth applying. It could be that the winder mechanism cable has snapped under the strain of trying to move a stuck glass, in which case a replacement of the mechanism is the solution - give me a shout if that is the case.....

AROC Vice-Chairman and Lancashire Section Secretary

Alfa organ donor to the gentry......
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , rear , ticking , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome