Power steering problem Pipes or Pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-05-11 Thread Starter
Status: Made a move from fords to Alfa GT
AO Member
01Billid's Avatar
Join Date: Jan 2010
Location: United Kingdom
County: West Midlands
Posts: 66

Member car:


Power steering problem Pipes or Pump

I'm trying to diagnose where and why the power steering liquid is leaking from my GT. I thought it could be the pipes as they are the old style ones which are not coated in plastic. However my friend down the pub said it could just as likely be the steering pump.

I have some photos here, (I have tried to clean some of the messy areas to see if they are wet while left).

Has anyone got an opinion or advise on where to look next.

01Billid is offline  
Sponsored Links
Status: missing my GTA
AO Silver Member
Join Date: Jan 2009
Location: United Kingdom
County: Lincolnshire
Posts: 1,589
hard to tell from the pics.

when I got my car it had a power steering leak. was simply the copper washer where the pipes meet the rack had given up and was allowing it to leak.

a good alfa specialist is the way to go here.
Artermis is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

pipes , power , problem , pump , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome