Breaking problems when engine changed... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-04-11 Thread Starter
Status: Rh - C8H18
AO Member
Speedmaster's Avatar
Join Date: Nov 2009
Location: Bulgaria
County: Stara Zagora
Posts: 337
Images: 44
Breaking problems when engine changed...

I recently changed engines between my 156's, one will be used only for trackdays, with 2.5V6 engine,transfered from my other car, now with 2.0TS.......
Track car was stationary for 2 months, discs bit rusty, but after 80 - 100km still no that breaking performance that i really get used to it. Today i removed ABS lead and with hard breaking from 80kmh, i just hear tyres to the road - when ABS on, it kicks only after really hard the other hand my 2.0TS breaks like hell, just touch the pedal and great bite.
Did not change servos when changed engines.......when i remove vacuum hose from the intake when car 20 min off, i'm unable to blow or suck into it, and that's OK, when remove the valve from servo, pssssstttt can be heard, so it holds vacuum......i noticed that when on idle and break pedal hardly pressed, when i blip the gas and breaks pedal goes for another 20-30mm down......
Any ideas, what can cause this????
Have spare servo, break master cyl, ABS unit, and if unable to find the cause, maybe will change it all.......

Rear Wheel Drive Mid - Engined Alfa 156 3.0 V6 '99 - trackday car
Alfa 156 2.0 TS '00 - daily car

Fiat Coupe 20VTurbo, GT2860RS,
water-meth injection 120cc, custom manifold, 3" Downpipe, FMIC - entertainment car
Speedmaster is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

breaking , changed , engine , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome