air con 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 24-04-11 Thread Starter
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Berkshire
Posts: 11

Member car:

147 1.6 TS

air con 147

The air con on my 147 doesn't seem to work at all (bought the car 2 weeks ago). With the hot weather in the UK at the moment (im near London) I can't stand to wait much longer than 5-7 minutes in the car without opening the windows. How long should it take to cool down and stop blowing hot air in your face (from a cold engine - first start in the morning)? I'm worried the whole system doesn't work and it'll be very expensive to fix. Thanks in advance for any comments!
millsd44 is offline  
Sponsored Links
Status: back in an Alfa :)
AO Member
Tanis8472's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Lincolnshire
Posts: 791
Id say you need to get it pressure checked/regassed.
Tanis8472 is offline  
Status: loving a shiny bella called Monica
AO Silver Member
bigjim's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Northamptonshire
Posts: 1,916

Member car:

159 2.4 Lusso

sounds like you need an aircon specialist to look at that.
bigjim is offline  
Status: S/W ,gtv sold, Mito 1.3jtdm
AO Member
alfafanatic100's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Dorset
Posts: 559

Member car:

156 sw / gtv

My car is blowing cold air within a couple of minutes, its a very efficient system on my sportwagon and the cabin
is comfortable within 5 mins max.
65 regas at peugeot dealer a couple of years ago which included draining old gas and a leak test before a full regas, worth every penny
alfafanatic100 is offline  
Status: drifter
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: West Sussex
Posts: 1,067
Undo one of the small circular black plastic covers fitted to the pipes on top of the airconditioning unit.This will reveal an insert identical in appearance to a tyre value insert. If you push it down for a split second and no gas comes out your system needs regassing.Obviously it maybe cos of a leak somewhere.
seymour beaver is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

I seem to remember reading on here somewhere, that somebody else had the same problem with an older 147, and turned the whole heater / control system to " OFF " before starting the Car, and that somehow cleared the whole system, including the Air Conditioning. Might be worth a try maybe !!!!.......

Hope that helps somewhat.......
n13roy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , air , con

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome