Immobilizer failure and constant clicking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 23-04-11 Thread Starter
Status: -
AO Member
Join Date: Jul 2006
Posts: 93

Member car:

147 1.6TS Lusso

Immobilizer failure and constant clicking

Hi all

I have a serious issue with my 147 i'm hoping someone can help me with..

I have had my 147 laid up for the past 12 months, last week I popped on a new battery, checked fluids and tried to start it, it fired first time no problem and sounds fine, I drove it a little and parked it up again.

Come to start today and it wont, when I turn on the ignition I get 'immobilizer failure' message, the engine symbol on the dash flashing very quickly in rhythm to a clicking noise coming from the fuel injection manifold, it seems to be the butterfly valve that is clicking, sometimes the immobilizer relay clicks as well... engine turns but doesn't start.

I have disconnected and reconnected all connections to the manifold, popped out and changed the relays but with no joy...

Any suggestions would be gratefully received.

Thanks for looking

dave_v2 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Check the battery charge...maybe something is draining it.
iainfm is offline  
Status: drifter
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: West Sussex
Posts: 1,067
I was starting to think i was drunk on one can of beer cos i could have sworn i had repied then i noticed its been entered twice
seymour beaver is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clicking , constant , failure , immobilizer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome