166 Q's from a new owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-08-04 Thread Starter
Status: -
AO Member
Join Date: Aug 2004
Posts: 14

Member car:

166 3.0

166 Q's from a new owner

Hi, after years of admiring Alfas from afar, I've taken the plunge and bought myself a 166 3.0 litre, with the 6-speed manual gearbox. My car is 4 years old, has 63000 miles on the clock with a full Alfa service history.

It's a fantastic car: the most amazing sonorous engine, with a free revving nature that is great for the open road, combined with flexibility that makes town driving a doddle. The chassis is very agile for a car of its size, and retains a composed feel, except on very bumpy twisties, where the suspension gets a little behind itself. The interior is excellent: it's got that Germanic solid feel to it, but has real style and warmth that the Germans don't have. The lack of cup holders is noted and approved of! The exterior styling has grown on me, long and low, with a 'widebody' look about it.

Anyway, my questions:

1) Despite an extended test drive, I forgot to check the cruise control and the darn thing doesn't work. The fuse is okay; has anyone had any experience of fixing the said device?

2) A couple of pieces of interior trim are missing/broken, can anyone point me in the direction of a second-hand Alfa parts dealer?

Cheers, Paddy

Last edited by B735; 01-08-04 at 21:05.
B735 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2003
Location: Surrey
Posts: 299

Member car:

166 V6 3.0

Re: 166 Q's from a new owner

Glad you like your car, I've had mine 3 years and I still think it's great. My cruise didn't work and I don't know what the problem was but my dealer fixed it free of charge - so it must have been simple (a loose cable or something.) It's worth fixing, I use it a lot.

mikealdren is offline  
(Post Link) post #3 of 3 Old 01-08-04 Thread Starter
Status: -
AO Member
Join Date: Aug 2004
Posts: 14

Member car:

166 3.0

cruise control

Thanks Mike!

Can anyone give me an idea of where to look in the engine bay for said item? Thinking about it, I doubt it is a separate it's separate module.
B735 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

166 , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome