Accelerator and power. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-04-11 Thread Starter
Status: Thinking of getting a 159
AO Member
NinJaSkrtel's Avatar
Join Date: Mar 2011
Location: Sweden
County: Värmland
Posts: 87

Member car:


Accelerator and power.

When I put my foot down, I seem to get the same power when its 3/4's of the way down that I get when my foot is flat to the floor.

On a 156 1.8 ts

Is this normal or have I got a problem?
NinJaSkrtel is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Maybe your throttle cable needs adjusting...Have someone operate the throttle while you watch it and see if it's opening fully.

Might also be the throttle position sensor though.
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

accelerator , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome