engine management light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-03-11 Thread Starter
Status: -
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Kent
Posts: 13

Member car:

alfa 156

engine management light

Hi. the engine management light has come on on my 2001 2.0 156. there really is no apparent reason,it is running perfectly. any thing i should try to clear it before i have to pay for diagnostics?

Many thanks
sibo63 is offline  
Sponsored Links
Status: obsessed
AO Silver Member
Loknar's Avatar
Join Date: Mar 2011
Location: Thailand
County: Bangkok
Posts: 1,407
Images: 76
Don't take any chances. If you're short on cash, maybe use a KKL cable to connect to your PC and see diagnostic.

If it were my 156, I would not use the engine anymore until resolved by trusted mechanic.
Loknar is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome