Mystery battery discharge.....all switched off? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 22-03-11 Thread Starter
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: -
Posts: 11

Member car:


Help Mystery battery discharge.....all switched off?

Hi - puzzled.

Yesterday morning I had a warning message saying "left light inoperable" or somesuch. The headlights and flashers seemed ok so I thought nothing more of it. Got back to station last night after a boringly deelayed journey to find that key fob would unlock car remotely. So unlocked with key but car wouldn't even turnover, just made a few feeble clicking noises.

With all the appearnce of an electrical problem, the AA were called and noted the battery was reading 6V. They jumped me but also noted that the battery was draining (2 amp?) even when everything was switched off. I know there is often a trickle of power needed on a modern car but he was surprised to see this amount.

I got home ok and disconnected the battery to prevent discharge.

Ring any bells for anyone?


Gesmi is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
You need to isolate the circuit that's drawing the current by pulling fuses one at a time, then take it from there I guess...
iainfm is offline  
Status: permanently confused
AO Silver Member
Sunbar's Avatar
Join Date: Mar 2003
County: -
Posts: 2,425

Member car:

MINI Cooper

Originally Posted by Gesmi View Post
Hi - puzzled.
... I know there is often a trickle of power needed on a modern car but he was surprised to see this amount.


About 0.3 - 0.25 amp is the maximum after all systems have shut down (20-30minutes after switch-off) from memory.
Sunbar is offline  
Status: -
AO Member
super164's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Kent
Posts: 347
Images: 28

Member car:

159 2.4

super164 is offline  
Status: Disillusioned and Disgruntled
Club Member
Membro Premio
MrShusky's Avatar
Club Member Number: 1299
Join Date: Jun 2010
Location: United Kingdom
County: West Midlands
Posts: 5,385
Don't know if it's any help but I once had a glove box light stay on due to faulty switch which drained the battery so first check if everything is properly off.
MrShusky is offline  
Status: :( sold the GT!
AO Member
stathe174's Avatar
Join Date: Feb 2010
Location: Greece
County: Attica
Posts: 84
Or check if your alarm is working properly...
stathe174 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , dischargeall , mystery , switched

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome