Getting me started - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-03-11 Thread Starter
Status: -
AO Member
Join Date: Mar 2011
Location: United Kingdom
County: Lancashire
Posts: 147

Member car:

159 2.4JTDm

Getting me started

Hey all

2 weeks ago my old car (dont worry not A.R) that i've had since uni days decided to self detonate on me at 120,000 miles. As such decided to buy or rather could not resist buying a near perfect conditon (mechanical and paintwork) 156 TS Veloce in red. So proud of it!

However only thing that im struggling with (at th moment) is the tire PSI, I have 17" alloys on and have read different answers on here about pressure being either 30-39! PSI. Anyone know what the correct pressure is?

Also anyone know a place (in lancs) that can put on low profile tires? Had a look round on internet but no joy!

Cheers for knowlegde guys

Yatesuk is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
I put about 36 in mine....
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome