motor control system failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-03-11 Thread Starter
Status: -
Join Date: Mar 2011
Location: United Kingdom
County: East Renfrewshire
Posts: 1
motor control system failure

Hello i have an alfa 2002 alfa1 56 2.0 jts. Iv had it nearly a year . Iv jad a warning motor controll system failure light on the dash since i bought it. Iv had several diagnostics tests done including 1 this week and i keep getting told its the mass air flow meter although iv replaced tis twice and its made no differace. And now it keeps cutting out on me in the morning can any 1 halelp
gavin83 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Cutting out soon as it's started, or after it's warmed up a bit?
iainfm is offline  
Status: Saving for engine.
AO Silver Member
tomfromtelford's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,244
Images: 54
Cam sensor?
tomfromtelford is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motor , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome