Intermittend rough idling and power loss. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-03-11 Thread Starter
Status: -
AO Member
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Intermittend rough idling and power loss.

Hi Guys

Iíve got this problem I suspect could be a MAF fault. I drive a 2005 156 2.4 JTD 20V. Symptoms is as follows :
1 - Intermittent rough idling.
2 - Intermittent sudden loss of power while accelerating, or cruising. It literally feels like my foot slips of the accelerator.
3 - Intermittent inability to rev. It normally goes hand in hand with point 1. It will rev, but VERY slowly and rough, with a huge accompanying black smoke cloud. In these instances I literally donít have enough power to pull away.
I have hooked up my laptop with Fiat ECUscan, and got a few error codes.
P1237 Ė Air intake 1
P1238 Ė Air intake 2

As well as 2 others which I canít recall now, but mentioned a problem with earthing.

I also noticed that the parameters for Desired Air intake and actual air intake differs by about 50 %. It is much more prominent while experiencing the rough idling and power loss.

Am I correct in assuming this could be a MAF problem ?

Any help or ideas would be appreciated.
Lourens is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Check all intake hoses (inc turbo related) for splits etc & that they are all tightened properly
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

idling , intermittend , loss , power , rough

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome