Belt squeal !! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-03-11 Thread Starter
Status: No remission for LUFC !!
AO Silver Member
ronan's Avatar
Join Date: Aug 2009
Location: Belfast
County: Down
Posts: 3,044

Member car:

156 1.8 Turismo

Belt squeal !!

Right chaps

I've a dreadful squeal on start up and it doesn't go away for at least 30's quite embarrassing !!

Now by a process of elimination it's not coming from the main cambelt area.

Now i know this might be mad...and if it is i'll stop doing it....but i sprayed (gently) water onto the balance belt area and it solved the problem. lack of lubrication...but when this dries up,i'm back to square one.

Is there anything i can spray on that will fix this.....i'm afraid to use WD40.

Please put me right.

ronan is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,865
Sounds like the belt is too slack.
Rockhopper is offline  
Status: -
AO Member
Join Date: Jun 2010
Location: United Kingdom
County: Surrey
Posts: 444

Member car:

147 selespeed

i just had the same on a 147? i thought it was the plastic tensioner so i changed it, the belt was abit of an ars to get back on if you do it yourself it would make life easier to get someone to pull it back over the top pully whlie you lever the tensioner, but after all that twisted the key and it sounded like a cat was stuck between the belt and the pully? so then swaped the belt with a engine i had laying about? BINGO. you right the its really annoying and makes your car sound like a right banger lol

good luck
antman147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

belt , squeal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome