vgt actuator - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
Join Date: Apr 2010
Location: Serbia
County: -
Posts: 1

Member car:

156 2.4 20v

Don't fool around with overboost issue. I drove my 156 2.4 jtd 20v for about a year with that problem. When i finally went to some experienced guys it turned out that not only VGT is stuck, but overboost caused turbo to spin too fast too often so it was damaged and i have to recondition it...costing me too much...they say that if i reacted immediately, it would be just an issue of cleaning turbo, not reconditioning...
Novialfista is offline  
Sponsored Links
Status: - Update
Posts: n/a
Just a quick query on this thread... The vacuum in the actuator 'pulls' the rod on engine sartup (max vacuum, low revs turbo position), but where is the spring located that pulls the rod back to its high revs (low vac) position... I think my overboost problem may be caused by the vanes not going back quickly enough (as it's an erratic fault) and I've replaced everything else - pipes, solenoid, MAP...

Cheers folks!
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
on the ones we build the spring is in the actuator, but its possible your vanes are sooted up stopping them moving

hdseven is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

actuator , vgt

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome