Rear LEDs? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 25-02-11 Thread Starter
Status: -
AO Member
V6_TOM's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Surrey
Posts: 241
Rear LEDs?

Hi all,

Recently upgraded my sidelights to LEDs, about to do the same to the rear number plate and whilst searching youtube came accross a few guys that have done it to the rear clusters.

After watching a few videos the difference between filament and LED is like night and day - particularly with the indicators:

YouTube - LED bulbs vs filament bulbs

Has anyone tried this on a 156, or would know which bulbs to get.

I can see there being problems with indicator timing and canbus errors.
V6_TOM is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
You don't have CANbus, so CANbus errors are not an issue!
What is a big issue though is the difference in brightness the brake & side lights at the rear with LEDs.
A 159 owner on here tried them and you could not tell when the brakes were on. So a MASSIVE safety issue...

Remember, there is a big difference between OEM LEDs and eBay LEDs.
David C is online now  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Constructions and Use, Road Traffic Act. Politzei zer' nickin' fer zee, Mein Schatz?
zulu ferret is offline  
Status: Wearing nowt but my boxers
AO Member
PhiliusMaximus's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Tyne and Wear
Posts: 365
Images: 10

Member car:

GT 3.2 V6

Watched a few of those videos. A few people keep going on about how the LEDs lower power consumption releases extra horsepower... Maybe the same people that sell the 20 quid EBay chips that give amazing power and fuel consumption lol!
PhiliusMaximus is offline  
Status: All's well this end
AO Silver Member
Hazz37's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: East Renfrewshire
Posts: 1,583
Images: 10
Was driving behind a Audi earlier with LED numberplate lights........horrible.......
Hazz37 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

leds , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome