What a f**king, stupid, annoying... arrghhh! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-02-11 Thread Starter
Status: -
Join Date: Mar 2010
County: -
Posts: 858

Member car:


Madness What a f**king, stupid, annoying... arrghhh!

So, I decided to do an oil and filter change yesterday. After discovering that one of the threads that the undertray bolts to was just spinning in the chassis leg and realising I'd have to prise that bit off (plus spotting that two of the bots holding the corners of the tray to the bumper had previously been sheared) I proceeded with the oil change and then went to do the air filter. Anyone who has done the job on a GT will know that it is the most idiotic of designs for a serviceable part in terms of access.

Anyhoo, after removing the front fusebox and popping various fixings out of their locations I had enough access to slide the new filter in, but a quick look around revealed that whoever had done the job previously had removed the two bolts connecting the outlet of the airbox to the turbo hard pipe and had only put one of them back. When I decided to fit a bolt there I realised why he/she had decided not to bother - after I had removed the battery, battery plate and most of the right hand side of the engine bay, along with the skin on both my handsl.

Re-assembling everything (7 hours later) and I called it a day.

Went to work this morning and first thing I was aware of was that my reverse-park sensors weren't working. Neither were my reversing lights.

Yep, that's right - I've since discovered that I've ripped the wires out of the reversing light switch on the top of the gearbox while removing the battery plate.

Only bright side is that it took me one search here to realise what the problem was.
agent smith is offline  
Sponsored Links
Status: 2016 . . . .Year ofthe Sprint??
AO Silver Member
StescoG66's Avatar
Join Date: May 2007
Location: United Kingdom
County: East Dunbartonshire
Posts: 3,196
Images: 17
I'm not a betting man, but to me that sounds like a full Arnold Clark service history . . . . . . . .
StescoG66 is offline  
(Post Link) post #3 of 3 Old 21-02-11 Thread Starter
Status: -
Join Date: Mar 2010
County: -
Posts: 858

Member car:


Possibly, although AFAIK the only 'service' they did was the one before I collected, and it was a Toyota franchise...

I suspect whoever did it was the same idiot who didn't put the gear linkage back properly and caused 400 worth of damage to the aircon pipe.

I'm putting this all down to experience and not rising to the 'it's an Alfa' crap because so far every problem has been down to idiotic workmanship post assembly (and I include myself in that re. the reversing switch.....)
agent smith is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

annoying , arrghhh , fking , stupid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome