My New Alfa! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-02-11 Thread Starter
Status: -
Join Date: Feb 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 8
My New Alfa!

Hi All,

I am a new member and onto my second Alfa. A 146 1.6 which was my first car & now a 159 115bhp JTD Veloce. Got a few questions and would massively appreciate your advice & help! (Hope that's not cheeky?)

1- The car is an 04 and has done 47774 miles. It has had basic services but not a cambelt change as per the 72,000 / 5 year recommendations. Would it be adviseable to do this asap or should i leave it 'til closer to 72k? £300?

2- The glow plug light is flashing after start up for about 10 seconds. Does this mean that glow plugs need changing? Will that cost a fortune? Would i do this at the same time as Cambelt if needed doing?

3- Had a VDC failure come up on start up and car didn't start. Turned key off and on again and it starts without the warning re-appearing. Any ideas or is it just an Alfa-rism?

4- Anybody on here know anything about Alfatec in Whitley Bay Tyne & Wear? Are they any good and are they reasonably priced?

5- Anybody upgraded their power from 115 to 145 bhp using one of those ECU modifiers and does it also increase MPG?

Thanks in advance for your advice, hope to use this site loads in the future...
Rossi_T_ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome