156 Brakes SW - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 15-02-11 Thread Starter
Status: Going Crazy Over Wishbones
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: Berkshire
Posts: 54
156 Brakes SW

Hi all...
I've been getting noises from my brakes which are indicative of them needing replaced.. Grinding when cold, squeeling.. When I got the car last month the seller advised that the rear pads were getting low and that's what the cause was, and even threw in a set of rear brake pads (happy days)..
When I went to replace them, the disc was in fairly new condition and pads were about the same, so I cleaned and re-greased them up and refitted...
But the noise is still there, but to me it sounds like the NSF is the culprit.. BUT (isn't there always) the front discs and pads were changed in Dec'10.. Paperwork to prove, however not done by a garage..
I'm gonna get the front end jacked up and look at the front discs etc and see what's going on..!!

Any ideas at to what could be causing my noises etc..

NB the brakes feel nice and sharp when the pedal is pressed.
AlphaRoss is offline  
Sponsored Links
Status: petrol fumes
AO Member
steve7's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Cumbria
Posts: 95

Member car:

156 2.0 JTS

I have a squeal at the back, pull hand brake and it goes away,
I was advised today to have rotors and pads replaced, it was mentioned non approved alfa pads can cause noises, guess they dont like going fast
So I would look at the make of the pads, but then Im no expert on these things, just throwing my thoughts in the ring.
steve7 is offline  
Status: - Update
Posts: n/a
The grinding when cold could just be flash rust that has built up on the disc overnight. I move mine for the first time since Friday this morning and it sounded like the pads were down to the metal. 2 or 3 applications and normal service was resumed.

Looking through the wheel with a torch should give an indication of whether the discs are fairly new or not.
(Post Link) post #4 of 4 Old 16-02-11 Thread Starter
Status: Going Crazy Over Wishbones
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: Berkshire
Posts: 54
Keith, mine is exactly like that for the first 2 / 3 brakings.. Then they are fine.. Just a bit squeeky.. But these can just be greased to fix...
Saves be 80 I guess, so that's some new sparky's then :-)
AlphaRoss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , brakes

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome