GT JTDm ECU errors P0226 & P0704 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-02-11 Thread Starter
Status: -
Join Date: Feb 2011
Location: United Kingdom
County: Essex
Posts: 1

Member car:


GT JTDm ECU errors P0226 & P0704


I have a 2005 GT JTDm and I'm having problems with the engine control systems failure light coming on. I have the FiatECU scan software and when I check the stored errors I find the following two error codes 'P0226 - TP Sensor/Switch' and 'P0704 - Transmission/Gear Sys'. Error code P0226 causes the light to stay on and relates to the throttle position sensor and the error P0704 is for clutch pedal switch signal circuit malfunction.
When the errors occurs the throttle is very lumpy with drops in power & often goes into limp home mode, quite often stopping and keying off for a few minutes stops these affects, the light still stays on but the errors aren't live. Clearing the codes with FiatECUscan seems to work for a few days or weeks but eventually the problem comes back.

Has anyone had this problem before? Do I need to replace the throttle pot? Is there anything that can be done with the diagnostic software which will help? I have read about the ECU reset, would this help in this case?

I am due to have the car serviced next week and could get them to do any work if need be.

Any help would be appreciated on this.

Prestogj is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2011
Location: United Kingdom
County: Dorset
Posts: 60

Member car:

159 1.9 JTD

Same problem

Hi, I have the same problem as you, the error code

P0704 - Transmission/Gear Sys (5)
Clutch Pedal Switch Signal Circuit Malfunction

is stored and the engine loses power.

Did you fix this?
benallenuk is offline  
Status: To GTB or not to GTB?
AO Silver Member
TribesMan's Avatar
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,228
Try replacing switch under the clutch pedal...
TribesMan is offline  
Status: -
AO Member
Join Date: Aug 2011
Location: United Kingdom
County: Dorset
Posts: 60

Member car:

159 1.9 JTD

I used FiatECU scan and it registered the clutch pedel switch ok. Will keep an eye on it.
benallenuk is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ecu , errors , jtdm , p0226 , p0704

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome