Help-flat/shaky acceleration on 147 JTDM - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-02-11 Thread Starter
Status: -
Join Date: Mar 2010
Location: United Kingdom
County: Hertfordshire
Posts: 9
Help-flat/shaky acceleration on 147 JTDM

Sorry I'm not quite sure how best to describe the problem but there seems to be flat spots, or rather shaky spots on power delivery when on light partial throttle between 1800-3000rpm, it feels almost as if there is a slight blocking on a petrol fuel injection car.
I've used Redex diesel clear out but still I get these spots which I dont get on full acceleration.

Any ideas?

daave77 is offline  
Sponsored Links
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
MAF problem is one option
EGR can be too
satanism is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , acceleration , helpflat or shaky , jtdm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome